Delayed Settlement Due to Ethereum Network Congestion

Incident Report for Project Alice

Resolved

Network congestion has cleared and settlements are now occurring at expected rates.
Posted May 21, 2024 - 08:54 UTC

Monitoring

Significantly increased congestion on the Ethereum and Optimism networks is causing delayed settlements. Orders will continue to be traded at the quoted price, however settlements could take longer to be deposited in accounts.
Posted May 20, 2024 - 20:47 UTC
This incident affected: Production (Ethereum Mainnet, Optimism Mainnet).